update sshfs to latest version, fix compile error
[openwrt/svn-archive/archive.git] / net / sshfs / Makefile
index 29c3bea3329fc916483c8fc0077b14eb9db53027..f373c100ce169904a64401d62992ed901f99e7a4 100644 (file)
@@ -4,17 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sshfs
-PKG_VERSION:=1.7
+PKG_VERSION:=1.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-fuse-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/fuse
-PKG_MD5SUM:=e91a2fed1da952a375798408dc6e41a0
+PKG_MD5SUM:=3c575cf89a6d3d8ab6063c2f60bd5b25
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-fuse-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -27,20 +27,22 @@ define Package/sshfs
   DEPENDS:=+libfuse +fuse-utils +glib2
   SECTION:=net
   CATEGORY:=Network
-  DESCRIPTION:=\
-       Mount remote system over sftp.
   URL:=http://fuse.sourceforge.net/
 endef
 
+define Package/sshfs/description
+       Mount remote system over sftp.
+endef
+
 CONFIGURE_VARS += \
        SSHFS_CFLAGS=" \
                -D_FILE_OFFSET_BITS=64 \
                -I$(STAGING_DIR)/usr/lib/libintl/include \
                -I$(STAGING_DIR)/usr/lib/libiconv/include \
                -I$(STAGING_DIR)/usr/include/glib-2.0 \
-               -I$(STAGING_DIR)/usr/include/glib-2.0/glib" \
+               -I$(STAGING_DIR)/usr/lib/glib-2.0/include" \
        SSHFS_LIBS=" \
-               -lglib-2.0 -lintl -liconv -lfuse -pthread \
+               -lglib-2.0 -lintl -liconv -lfuse -pthread -lgthread-2.0 \
                -L$(STAGING_DIR)/usr/lib/libintl/lib \
                -L$(STAGING_DIR)/usr/lib/libiconv/lib"