[packages] pulseaudio: fix missing backspace, binary junk in initscript
[openwrt/svn-archive/archive.git] / net / sshtunnel / Makefile
index daf16b21b9ebc3cd265c1aaa06f82eeade9992c4..c704004c68bcafa43e020f4a2408776bb112d471 100644 (file)
@@ -8,21 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sshtunnel
-PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_VERSION:=3
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sshtunnel
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=SSH
   TITLE:=Manages Local and Remote openssh ssh(1) tunnels
   MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
   DEPENDS:=+openssh-client
 endef
 
 define Package/sshtunnel/description
-Creates openssh ssh(1) Local and Remote tunnels configured in UCI file. Can be user to allow remote connections, possibly over NATed connections or without public IP/DNS
+Creates openssh ssh(1) Local and Remote tunnels configured in UCI file. Can be used to allow remote connections, possibly over NATed connections or without public IP/DNS
 endef
 
 define Package/sshtunnel/conffiles
@@ -33,7 +34,12 @@ define Build/Compile
 endef
 
 define Package/sshtunnel/install
-       $(CP) ./files/* $(1)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/initd_sshtunnel $(1)/etc/init.d/sshtunnel
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) ./files/sshtunnel.sh $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/uci_sshtunnel $(1)/etc/config/sshtunnel
 endef
 
 $(eval $(call BuildPackage,sshtunnel))