unfs3 is not parallel build safe
[openwrt/svn-archive/archive.git] / net / strongswan4 / Makefile
index aaf0d667348b218aed8ffb0d05210c395f0b4c88..df7d1110724c64535c9b3d0b66314e7bec5b1594 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
-PKG_VERSION:=4.3.6
+PKG_VERSION:=4.3.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.strongswan.org/
-PKG_MD5SUM:=e071f46b6c463ce76900758734e6143e
+PKG_MD5SUM:=02adcea934ef536e704d03c5d0f934f8
 
 PKG_MOD_AVAILABLE:= \
        aes \
@@ -65,6 +65,8 @@ PKG_BUILD_DEPENDS:= \
 PKG_CONFIG_DEPENDS:= \
        CONFIG_STRONGSWAN4_ENABLE_CISCO_QUIRKS \
        CONFIG_STRONGSWAN4_ENABLE_NAT_TRANSPORT \
+       CONFIG_STRONGSWAN4_ENABLE_VENDOR_ID \
+       CONFIG_STRONGSWAN4_ENABLE_XAUTH_VID \
        CONFIG_STRONGSWAN4_DEVICE_RANDOM \
        CONFIG_STRONGSWAN4_DEVICE_URANDOM \
        CONFIG_STRONGSWAN4_ROUTING_TABLE \
@@ -73,11 +75,13 @@ PKG_CONFIG_DEPENDS:= \
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 define Package/strongswan4/Default
+  SUBMENU:=VPN
   SECTION:=net
   CATEGORY:=Network
   TITLE:=StrongSwan
@@ -93,6 +97,7 @@ endef
 define Package/strongswan4
 $(call Package/strongswan4/Default)
   DEPENDS:= +libpthread +ip \
+       +kmod-crypto-authenc \
        +kmod-ipsec +kmod-ipsec4 \
        +kmod-ipt-ipsec +iptables-mod-ipsec
   MENU:=1
@@ -139,7 +144,7 @@ $(call Package/strongswan4/Default)
        +strongswan4-mod-medcli \
        +strongswan4-mod-medsrv \
        +strongswan4-mod-mysql \
-       +strongswan4-mod-padlock \
+       +TARGET_x86:strongswan4-mod-padlock \
        +strongswan4-mod-pem \
        +strongswan4-mod-pgp \
        +strongswan4-mod-pkcs1 \
@@ -166,6 +171,43 @@ $(call Package/strongswan4/description/Default)
 endef
 
 
+define Package/strongswan4-default
+$(call Package/strongswan4/Default)
+  TITLE+= (default)
+  DEPENDS:= strongswan4 \
+       +strongswan4-app-charon \
+       +strongswan4-app-pluto \
+       +strongswan4-mod-aes \
+       +strongswan4-mod-attr \
+       +strongswan4-mod-des \
+       +strongswan4-mod-dnskey \
+       +strongswan4-mod-fips-prf \
+       +strongswan4-mod-gmp \
+       +strongswan4-mod-hmac \
+       +strongswan4-mod-md5 \
+       +strongswan4-mod-pem \
+       +strongswan4-mod-pgp \
+       +strongswan4-mod-pkcs1 \
+       +strongswan4-mod-pubkey \
+       +strongswan4-mod-random \
+       +strongswan4-mod-resolve \
+       +strongswan4-mod-sha1 \
+       +strongswan4-mod-sha2 \
+       +strongswan4-mod-stroke \
+       +strongswan4-mod-updown \
+       +strongswan4-mod-x509 \
+       +strongswan4-mod-xcbc \
+       +strongswan4-utils
+endef
+
+define Package/strongswan4-default/description
+$(call Package/strongswan4/description/Default)
+ .
+ This meta-package contains only dependencies to match upstream
+ defaults.
+endef
+
+
 define Package/strongswan4-minimal
 $(call Package/strongswan4/Default)
   TITLE+= (minimal)
@@ -235,7 +277,7 @@ endef
 define BuildPlugin
   define Package/strongswan4-mod-$(1)
     $$(call Package/strongswan4/Default)
-    TITLE:= StronSwan $(2) plugin
+    TITLE:= StrongSwan $(2) plugin
     DEPENDS:= strongswan4 $(3)
   endef
 
@@ -254,11 +296,13 @@ endef
 CONFIGURE_ARGS+= \
        $(if $(CONFIG_STRONGSWAN4_ENABLE_CISCO_QUIRKS),--enable-cisco-quirks,--disable-cisco-quirks) \
        $(if $(CONFIG_STRONGSWAN4_ENABLE_NAT_TRANSPORT),--enable-nat-transport,--disable-nat-transport) \
+       $(if $(CONFIG_STRONGSWAN4_ENABLE_VENDOR_ID),--enable-vendor-id,--disable-vendor-id) \
+       $(if $(CONFIG_STRONGSWAN4_ENABLE_XAUTH_VID),--enable-xauth-vid,--disable-xauth-vid) \
        --disable-scripts \
        --disable-static \
        $(if $(CONFIG_PACKAGE_strongswan4-utils),--enable-tools,--disable-tools) \
        --with-random-device="$(call qstrip,$(CONFIG_STRONGSWAN4_DEVICE_RANDOM))" \
-       --with-urandom-device="$(call qstrip,$(CONFIG_STRONGSWAN4_DEVICE_RANDOM))" \
+       --with-urandom-device="$(call qstrip,$(CONFIG_STRONGSWAN4_DEVICE_URANDOM))" \
        --with-routing-table="$(call qstrip,$(CONFIG_STRONGSWAN4_ROUTING_TABLE))" \
        --with-routing-table-prio="$(call qstrip,$(CONFIG_STRONGSWAN4_ROUTING_TABLE_PRIO))" \
        $(foreach m,$(PKG_MOD_AVAILABLE), \
@@ -297,6 +341,11 @@ define Package/strongswan4/install
 endef
 
 
+define Package/strongswan4-default/install
+       true
+endef
+
+
 define Package/strongswan4-full/install
        true
 endef
@@ -352,6 +401,7 @@ endef
 
 
 $(eval $(call BuildPackage,strongswan4))
+$(eval $(call BuildPackage,strongswan4-default))
 $(eval $(call BuildPackage,strongswan4-full))
 $(eval $(call BuildPackage,strongswan4-minimal))
 $(eval $(call BuildPackage,strongswan4-app-charon))
@@ -381,8 +431,8 @@ $(eval $(call BuildPlugin,load-tester,load testing,))
 $(eval $(call BuildPlugin,md5,MD5 crypto,))
 $(eval $(call BuildPlugin,medcli,mediation client configuration database,))
 $(eval $(call BuildPlugin,medsrv,mediation server configuration database,))
-$(eval $(call BuildPlugin,mysql,MySQL database interface,+strongswan4-mod-sql +libmysqlclient))
-$(eval $(call BuildPlugin,padlock,VIA PadLock crypto,))
+$(eval $(call BuildPlugin,mysql,MySQL database interface,+strongswan4-mod-sql +PACKAGE_strongswan4-mod-mysql:libmysqlclient))
+$(eval $(call BuildPlugin,padlock,VIA PadLock crypto,@TARGET_x86))
 $(eval $(call BuildPlugin,pem,PEM decoding,))
 $(eval $(call BuildPlugin,pgp,PGP key decoding,))
 $(eval $(call BuildPlugin,pkcs1,PKCS1 key decoding,))
@@ -391,9 +441,9 @@ $(eval $(call BuildPlugin,random,RNG,))
 $(eval $(call BuildPlugin,resolve,DNS resolver,))
 $(eval $(call BuildPlugin,sha1,SHA1 crypto,))
 $(eval $(call BuildPlugin,sha2,SHA2 crypto,))
-$(eval $(call BuildPlugin,smp,SMP configuration and control interface,+libxml2))
+$(eval $(call BuildPlugin,smp,SMP configuration and control interface,+PACKAGE_strongswan4-mod-smp:libxml2))
 $(eval $(call BuildPlugin,sql,SQL database interface,))
-$(eval $(call BuildPlugin,sqlite,SQLite database interface,+strongswan4-mod-sql +libsqlite3))
+$(eval $(call BuildPlugin,sqlite,SQLite database interface,+strongswan4-mod-sql +PACKAGE_strongswan4-mod-sqlite:libsqlite3))
 $(eval $(call BuildPlugin,stroke,Stroke,))
 $(eval $(call BuildPlugin,uci,UCI config interface,+libuci))
 $(eval $(call BuildPlugin,updown,updown firewall,))