packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / stun / Makefile
index 86f94bbfe0eff52810caf01aec0a316c116ccce1..e7090bf660c82ef57952b2bc541aff079e2cc1fb 100644 (file)
@@ -1,15 +1,15 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stund
 PKG_VERSION:=0.96
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_Aug13.tgz
 PKG_SOURCE_URL:=@SF/stun
@@ -58,9 +58,8 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -L$(TOOLCHAIN_DIR)/usr/lib \
-                       -nodefaultlibs -luClibc++ $(LIBGCC_S)" \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$$$$LDFLAGS $(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ $(LIBGCC_S)" \
                all
 endef
 
@@ -69,11 +68,15 @@ define Package/stund/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/server $(1)/usr/sbin/stund
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/stund.init $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/stund.init $(1)/etc/init.d/stund
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/stund.config $(1)/etc/config/stund
 endef
 
+define Package/stund/conffiles
+/etc/config/stund
+endef
+
 define Package/stun-client/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/client $(1)/usr/sbin/stun-client