[packages] kismet: Remove finite prototype patch which is now fixed on uClibc (change...
[openwrt/svn-archive/archive.git] / net / stunnel / Makefile
index 3a3e28ad35ab8c89213c008d8806990355dc2bf7..93161e93863435dbd6d906a4ae1aab1bfc5fa9c1 100644 (file)
@@ -1,17 +1,12 @@
-# $Id: Makefile 1146 2005-06-05 13:32:28Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=4.20
+PKG_VERSION:=4.25
 PKG_RELEASE:=1
-PKG_MD5SUM:=cf9940395d3503018f721c962528d2ec
+PKG_MD5SUM:=7f00799f43910c0362df0e69c65965aa
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -20,9 +15,15 @@ define Package/stunnel
   CATEGORY:=Network
   DEPENDS:=+libopenssl +libwrap
   TITLE:=SSL TCP Wrapper
-  DESCRIPTION:=\
-        Open source SSL TCP Wrapper
-  URL:=http://stunnel.org
+  URL:=http://www.stunnel.org/
+endef
+
+define Package/stunnel/description
+       Stunnel is a program that allows you to encrypt arbitrary TCP
+       connections inside SSL (Secure Sockets Layer) available on both Unix
+       and Windows. Stunnel can allow you to secure non-SSL aware daemons and
+       protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
+       encryption, requiring no changes to the daemon's code. 
 endef
 
 
@@ -43,12 +44,14 @@ define Build/Compile
 endef
 
 define Package/stunnel/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/usr/lib $(1)/usr/stunnel
-       $(INSTALL_DIR) $(1)/etc/stunnel $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
-       $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
-       $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/stunnel
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
+       $(INSTALL_DIR) $(1)/etc/stunnel
+       $(INSTALL_CONF) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/stunnel
 endef
 
 $(eval $(call BuildPackage,stunnel))