[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / net / stunnel / Makefile
index 4693305f37c94142c36a459d0b86abc48dcdf880..c1f8aef71605c5ae5c42b51102eebd4c719a352f 100644 (file)
@@ -8,6 +8,8 @@ PKG_MD5SUM:=14dc3f8412947f0548975cbce74d6863
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/stunnel
@@ -41,9 +43,7 @@ endef
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
        echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Compile/Default)
 endef
 
 define Package/stunnel/install