[package] update stunnel to 4.29 (#6324)
[openwrt/svn-archive/archive.git] / net / stunnel / Makefile
index 0c53499eaa0ad25bbf99a492801c8ce5f6475b5b..ff16727c2a87c509402ca34b6498710a491b3495 100644 (file)
@@ -1,17 +1,12 @@
-# $Id: Makefile 1146 2005-06-05 13:32:28Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=4.16
+PKG_VERSION:=4.29
 PKG_RELEASE:=1
-PKG_MD5SUM:=8ea5cae3eeaacc0271b766506b4b9d4a
+PKG_MD5SUM:=14dc3f8412947f0548975cbce74d6863
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -20,20 +15,30 @@ define Package/stunnel
   CATEGORY:=Network
   DEPENDS:=+libopenssl +libwrap
   TITLE:=SSL TCP Wrapper
-  DESCRIPTION:=\
-        Open source SSL TCP Wrapper
-  URL:=http://stunnel.org
+  URL:=http://www.stunnel.org/
+endef
+
+define Package/stunnel/description
+       Stunnel is a program that allows you to encrypt arbitrary TCP
+       connections inside SSL (Secure Sockets Layer) available on both Unix
+       and Windows. Stunnel can allow you to secure non-SSL aware daemons and
+       protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
+       encryption, requiring no changes to the daemon's code.
 endef
 
+define Package/stunnel/conffiles
+/etc/stunnel/stunnel.conf
+endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-random=/dev/urandom \
                --with-threads=fork \
+               --with-ssl=$(STAGING_DIR)/usr \
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
        echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -41,13 +46,15 @@ define Build/Compile
                all install
 endef
 
-define Package/stunnel/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/usr/lib $(1)/usr/stunnel
-       $(INSTALL_DIR) $(1)/etc/stunnel $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
-       $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
-       $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
+define Package/stunnel/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/stunnel
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
+       $(INSTALL_DIR) $(1)/etc/stunnel
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.conf-sample $(1)/etc/stunnel/stunnel.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/stunnel
 endef
 
 $(eval $(call BuildPackage,stunnel))