lots of package cleanups/fixes
[openwrt/svn-archive/archive.git] / net / subversion / Makefile
index 9023f6f269a311ef87fd5904acba0c41b54ad929..d26cce30dbaddfe60751ad7d239f6bbcdbd360ea 100644 (file)
@@ -9,16 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
-PKG_VERSION:=1.4.4
+PKG_VERSION:=1.4.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
-PKG_MD5SUM:=
-PKG_CAT:=bzcat
+PKG_MD5SUM:=4c333a5fe827568c67d195cda7a5e154
 
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +24,7 @@ define Package/subversion/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A compelling replacement for CVS
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A compelling replacement for CVS
-  DEPENDS:=+zlib +neon +libintl +apr +apr-util
+  DEPENDS:=+zlib +libneon +libintl +libapr +libaprutil
   URL:=http://subversion.tigris.org/
   SUBMENU:=subversion
 endef
   URL:=http://subversion.tigris.org/
   SUBMENU:=subversion
 endef
@@ -48,36 +46,30 @@ define Package/subversion-server
   TITLE:=subversion server
 endef
 
   TITLE:=subversion server
 endef
 
-define Build/Configure 
-       $(call Build/Configure/Default, \
-               --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
-               --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
-               --with-neon="$(STAGING_DIR)/usr" \
-               --disable-mod-activation \
-               --without-ruby-sitedir \
-               --without-swig \
-               --with-jikes=no \
-               --without-junit \
-               --without-berkeley-db \
-               --with-ssl \
-               --disable-neon-version-check \
-               --with-apxs=no \
-               --with-apache=no \
-               , \
-               svn_lib_neon=yes \
-               LDFLAGS="-lcrypt -lnsl -lm -lintl -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
-                        -lz -L$(STAGING_DIR)/usr/lib/ \
-                        -lpthread -L$(STAGING_DIR)/lib" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include/ \
-                         -I$(STAGING_DIR)/usr/lib/libintl/include \
-                         -I$(STAGING_DIR)/include/" \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all local-install
+CONFIGURE_ARGS += \
+       --with-apr="$(STAGING_DIR)/host/bin/apr-1-config" \
+       --with-apr-util="$(STAGING_DIR)/host/bin/apu-1-config" \
+       --with-neon="$(STAGING_DIR)/usr/include/neon" \
+       --disable-mod-activation \
+       --without-ruby-sitedir \
+       --without-swig \
+       --with-jikes=no \
+       --without-junit \
+       --without-berkeley-db \
+       --with-ssl \
+       --disable-neon-version-check \
+       --with-apxs=no \
+       --with-apache=no \
+
+CONFIGURE_VARS += \
+       svn_lib_neon=yes \
+       LDFLAGS="-lcrypt -lnsl -lm -lintl -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
+               -lz -L$(STAGING_DIR)/usr/lib/ -lpthread -L$(STAGING_DIR)/lib" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include/ -I$(STAGING_DIR)/usr/lib/libintl/include \
+               -I$(STAGING_DIR)/include/" \
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all local-install
 endef
 
 define Package/subversion-libs/install
 endef
 
 define Package/subversion-libs/install
@@ -87,18 +79,18 @@ endef
 
 define Package/subversion-client/install
        $(INSTALL_DIR) $(1)/usr/bin
 
 define Package/subversion-client/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{svn,svnversion,svnsync} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{svn,svnversion,svnsync} $(1)/usr/bin/
 endef
 
 define Package/subversion-server/install
        $(INSTALL_DIR) $(1)/usr/bin
 endef
 
 define Package/subversion-server/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/svn{look,admin,dumpfilter,serve} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/svn{look,admin,dumpfilter,serve} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/subversion.config $(1)/etc/config/subversion
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/subversion.init $(1)/etc/init.d/subversion
 endef
 
 $(eval $(call BuildPackage,subversion-libs))
 $(eval $(call BuildPackage,subversion-client))
 $(eval $(call BuildPackage,subversion-server))
 endef
 
 $(eval $(call BuildPackage,subversion-libs))
 $(eval $(call BuildPackage,subversion-client))
 $(eval $(call BuildPackage,subversion-server))
-
-$(eval $(call RequireCommand,/usr/bin/ruby, \
-       $(PKG_NAME) requires ruby installed on the host-system. \
-))