unfs3: add support for compiling with the external librpc
[openwrt/svn-archive/archive.git] / net / subversion / Makefile
index 78eb622b9c08ee0d7a2118e011d0c08574f575df..dc8ec9bab249392812c780d006f21f4e94119473 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
-PKG_VERSION:=1.6.5
+PKG_VERSION:=1.6.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
-PKG_MD5SUM:=1a53a0e72bee0bf814f4da83a9b6a636
+PKG_SOURCE_URL:=http://subversion.tigris.org/downloads
+PKG_MD5SUM:=113fca1d9e4aa389d7dc2b210010fa69
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_MACRO_PATHS:=build/ac-macros
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,8 +24,8 @@ define Package/subversion/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A compelling replacement for CVS
-  DEPENDS:=+zlib +libneon +libintl +libaprutil
-  URL:=http://subversion.tigris.org/
+  DEPENDS:=+zlib +libneon +libaprutil
+  URL:=http://subversion.apache.org/
   SUBMENU:=Version Control Systems
 endef
 
@@ -75,7 +76,7 @@ endef
 CONFIGURE_ARGS += \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
-       --with-neon="$(STAGING_DIR)/usr/include/neon" \
+       --with-neon="$(STAGING_DIR)/usr" \
        --disable-mod-activation \
        --without-ruby-sitedir \
        --without-swig \
@@ -85,18 +86,19 @@ CONFIGURE_ARGS += \
        --with-ssl \
        --disable-neon-version-check \
        --with-apxs=no \
-       --with-apache=no \
        --without-sasl \
 
 CONFIGURE_VARS += \
        svn_lib_neon=yes \
-       LDFLAGS="$(TARGET_LDFLAGS) -lcrypt -lm -lintl -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
+       LDFLAGS="$(TARGET_LDFLAGS) -lcrypt -lm \
                -lz -lpthread -L$(TOOLCHAIN_DIR)/usr/lib \
                -L$(TOOLCHAIN_DIR)/lib" \
-       CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/lib/libintl/include" \
+       CPPFLAGS="$(TARGET_CPPFLAGS)" \
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all local-install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all local-install
 endef
 
 define Package/subversion-libs/install