[package] get the enable/disable ipv6 configure option from the build system, do...
[openwrt/svn-archive/archive.git] / net / tcpdump / Makefile
index a5dfb2698b717d55dc07de0c9e52467cf61f31f0..41c88c86a005776dffd943493f14f0f84580bf8e 100644 (file)
@@ -1,27 +1,22 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpdump
-PKG_VERSION:=3.9.4
-PKG_RELEASE:=1
+PKG_VERSION:=3.9.8
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
        http://ftp.gwdg.de/pub/misc/tcpdump/ \
        http://www.at.tcpdump.org/ \
        http://www.br.tcpdump.org/
-PKG_MD5SUM:=4b64755bbc8ba1af49c747271a6df5b8
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=c491a78c52fe73f1f7271aa5d8c6ab2e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,7 +30,6 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-ipv6 \
                --without-crypto \
                , \
                BUILD_CC="$(TARGET_CC)" \
@@ -46,14 +40,14 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include" \
+               CCOPT="$(TARGET_CFLAGS)" INCLS="-I. $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/tcpdump/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tcpdump $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tcpdump $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,tcpdump))