[package] get the enable/disable ipv6 configure option from the build system, do...
[openwrt/svn-archive/archive.git] / net / tcpdump / Makefile
index a733bb862f322761c0e5639a629e8476aec63176..41c88c86a005776dffd943493f14f0f84580bf8e 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpdump
 PKG_VERSION:=3.9.8
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
@@ -31,7 +30,6 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-ipv6 \
                --without-crypto \
                , \
                BUILD_CC="$(TARGET_CC)" \
@@ -42,7 +40,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include" \
+               CCOPT="$(TARGET_CFLAGS)" INCLS="-I. $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef