[package] add lsqlite3 (#5783)
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index 8dc1fac2a4da3291ad809f93d41f447e31157dc5..2eb4eca0c4ce7b4d6497ce0e44c48ffb9bc090e1 100644 (file)
@@ -4,31 +4,35 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.8
+PKG_VERSION:=1.0.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=1b59583b5bc57806459c81a413fb0cc4
+PKG_MD5SUM:=f907acebada53512e01235bea6b4cdf1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +zlib
+  DEPENDS:=+liblzo +libopenssl +kmod-tun
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
   SUBMENU:=VPN
 endef
 
+define Package/tinc/description
+  tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and
+  encryption to create a secure private network between hosts on the Internet.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel="$(LINUX_DIR)" \
@@ -43,7 +47,7 @@ define Build/Compile
                all install
 endef
 
-define Package/tinc/install    
+define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
 endef