[packages] gettext-full: install headers into usr/lib/gettext-full/include, makes...
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index 6457c84903c0df64207aaef6d5eb6a3af68106e6..67501767fb4659fdf0da0a9d06226dd4765f0d02 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.11
+PKG_VERSION:=1.0.13
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=ee0b1a3366c6e379cae34be6fa5dcb15
+PKG_MD5SUM:=86263994d38c750431efd17e9a91a248
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,19 +35,17 @@ define Package/tinc/description
   encryption to create a secure private network between hosts on the Internet.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-kernel="$(LINUX_DIR)" \
-               --with-zlib="$(STAGING_DIR)/usr" \
-               --with-lzo-include="$(STAGING_DIR)/usr/include/lzo" \
-       )
-endef
+TARGET_CFLAGS += -std=gnu99
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-zlib="$(STAGING_DIR)/usr" \
+       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo" \
+
+# XXX: checking for SHA1_version(), which is a variable, not a function,
+# fails on PowerPC, so just override it for now
+CONFIGURE_VARS += \
+       ac_cv_lib_crypto_SHA1_version="yes" \
 
 define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin