remove UninstallDev
[openwrt/svn-archive/archive.git] / net / tinyproxy / Makefile
index ec798dfd12257b55e8a8c86d3d35893f4a1fbf40..5556af821e88cc72b4d0e7acbc187e02cbc50c55 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/tinyproxy
 PKG_MD5SUM:=bd14d029b12621bcfd7ee71b2f4893da
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -47,14 +46,14 @@ define Build/Compile
 endef
 
 define Package/tinyproxy/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share/tinyproxy
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
-       install -d -m0755 $(1)/etc/tinyproxy
+       $(INSTALL_DIR) $(1)/etc/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/etc/tinyproxy/tinyproxy.conf $(1)/etc/tinyproxy/
-       install -d -m0755 $(1)/etc/init.d
-       $(CP) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
 endef
 
 $(eval $(call BuildPackage,tinyproxy))