merge r14585 to 8.091, thanks florida
[openwrt/svn-archive/archive.git] / net / tinyproxy / Makefile
index 3773cea77028266fc9b2fdf8d0a54a802e0b5a21..9925a97122fff01e77a2a2310c198a8e8e4ecb14 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.6.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.4
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/tinyproxy
-PKG_MD5SUM:=bd14d029b12621bcfd7ee71b2f4893da
+PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.6/
+PKG_MD5SUM:=3157b9159a8d005f4248cf4d4d6c65e2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +26,7 @@ define Package/tinyproxy
 endef
 
 define Package/tinyproxy/conffiles
-/etc/tinyproxy/tinyproxy.conf
+/etc/config/tinyproxy
 endef
 
 define Build/Configure
@@ -47,8 +47,8 @@ define Package/tinyproxy/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
-       $(INSTALL_DIR) $(1)/etc/tinyproxy
-       $(CP) $(PKG_INSTALL_DIR)/etc/tinyproxy/tinyproxy.conf $(1)/etc/tinyproxy/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(CP) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
 endef