unfs3: add support for compiling with the external librpc
[openwrt/svn-archive/archive.git] / net / tinyproxy / Makefile
index 11938b7388f2f00516a1ff6d49c5cebfbfa0ad3d..e12b43ad67b16449c7013c0a5b7a6ecaa83a69cb 100644 (file)
@@ -1,57 +1,50 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.6.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.8.2
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/tinyproxy
-PKG_MD5SUM:=bd14d029b12621bcfd7ee71b2f4893da
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
+PKG_MD5SUM:=edc8502193cfed4974d6a770da173755
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinyproxy
+  SUBMENU:=Proxy Servers
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
-  DESCRIPTION:=\
-       Tinyproxy is a lightweight HTTP and HTTPS proxy.\
-  URL:=http://tinyproxy.sourceforge.net
+  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
+  URL:=http://tinyproxy.sourceforge.net/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,\
-       --disable-static \
-       --enable-transparent-proxy \
-)
+define Package/tinyproxy/conffiles
+/etc/config/tinyproxy
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
-endef
+CONFIGURE_ARGS+= \
+       --enable-filter \
+       --enable-transparent \
+       --disable-regexcheck \
 
 define Package/tinyproxy/install
-       install -d -m0755 $(1)/usr/sbin \
-                               $(1)/etc/tinyproxy \
-                               $(1)/etc/init.d \
-                               $(1)/var/log \
-                               $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy $(1)/usr/share/
-       $(CP) $(PKG_INSTALL_DIR)/etc/tinyproxy $(1)/etc/
-       $(CP) files/tinyproxy.init $(1)/etc/init.d/tinyproxy
+       $(INSTALL_DIR) $(1)/usr/share/tinyproxy
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
 endef
 
 $(eval $(call BuildPackage,tinyproxy))