[PATCH] tinyproxy: allow to use the bind option
[openwrt/svn-archive/archive.git] / net / tinyproxy / Makefile
index 7d69c5a6b666c7f25adfe7c61cfb95a65988937c..e3dae220499d191639bc61e7a534349ca85e3e3e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,22 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.8.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.8.2
+PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
-PKG_MD5SUM:=09843d47828261394d0a30af0b058997
+PKG_MD5SUM:=edc8502193cfed4974d6a770da173755
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinyproxy
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
-  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
+  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
   URL:=http://tinyproxy.sourceforge.net/
 endef
 
@@ -31,17 +31,14 @@ define Package/tinyproxy/conffiles
 /etc/config/tinyproxy
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-filter \
-               --enable-transparent \
-               --enable-regexcheck=no \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-filter \
+       --enable-transparent \
+       --disable-regexcheck \
 
 define Package/tinyproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
        $(INSTALL_DIR) $(1)/etc/config