unfs3: add support for compiling with the external librpc
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index 684bd25979b88bb518d9c651193cf2b485f8b3db..495fae0906143f82bc25fccebbe1cc57bfc0f540 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,26 +8,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.2.1.25
+PKG_VERSION:=0.2.1.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.torproject.org/dist
-PKG_MD5SUM:=f58540b3c5835ac4f5de1b02bbddc703
+PKG_MD5SUM:=1cd4feea84f2b066717b500d090bcf65
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/tor
+define Package/tor/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread
-  TITLE:=An anonymous Internet communication system
   URL:=http://www.torproject.org/
 endef
 
-define Package/tor/description
+define Package/tor/Default/description
  Tor is a toolset for a wide range of organizations and people that want to
  improve their safety and security on the Internet. Using Tor can help you
  anonymize web browsing and publishing, instant messaging, IRC, SSH, and
@@ -35,6 +33,18 @@ define Package/tor/description
  new applications with built-in anonymity, safety, and privacy features.
 endef
 
+define Package/tor
+$(call Package/tor/Default)
+  TITLE:=An anonymous Internet communication system
+  DEPENDS:=+libevent +libopenssl +libpthread
+endef
+
+define Package/tor-geoip
+$(call Package/tor/Default)
+  TITLE:=GeoIP db for tor
+  DEPENDS:=+tor
+endef
+
 define Package/tor/conffiles
 /etc/tor/torrc
 endef
@@ -94,4 +104,10 @@ define Package/tor/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
+define Package/tor-geoip/install
+       $(INSTALL_DIR) $(1)/usr/share/tor
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor
+endef
+
 $(eval $(call BuildPackage,tor))
+$(eval $(call BuildPackage,tor-geoip))