[package] update tor to 0.2.1.24 (#6748)
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index 72a4e25e5e71b65f1db66ae768840f90b7bb5578..7105df8ec49b59688b8131d510c1dbde1fcb56e3 100644 (file)
@@ -1,38 +1,38 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.1.2.16
-PKG_RELEASE:=2
+PKG_VERSION:=0.2.1.24
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://tor.eff.org/dist/ \
-       http://ftp.se.linux.org/crypto/tor/ \
-       http://tor.meulie.net/
-PKG_MD5SUM:=f340777b3f6c3175de976856d2d2e4be
+PKG_SOURCE_URL:=http://www.torproject.org/dist
+PKG_MD5SUM:=cb5629b2709ada82d34c22fef3ed77a9
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tor
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread +zlib +libevent
+  DEPENDS:=+libevent +libopenssl +libpthread
   TITLE:=An anonymous Internet communication system
-  DESCRIPTION:=\
-       Tor is a toolset for a wide range of organizations and people that want \\\
-       to improve their safety and security on the Internet. Using Tor can \\\
-       help you anonymize web browsing and publishing, instant messaging, \\\
-       IRC, SSH, and more. Tor also provides a platform on which software \\\
-       developers can build new applications with built-in anonymity, safety, \\\
-       and privacy features.
-  URL:=http://tor.eff.org/
+  URL:=http://www.torproject.org/
+endef
+
+define Package/tor/description
+ Tor is a toolset for a wide range of organizations and people that want to
+ improve their safety and security on the Internet. Using Tor can help you
+ anonymize web browsing and publishing, instant messaging, IRC, SSH, and
+ more. Tor also provides a platform on which software developers can build
+ new applications with built-in anonymity, safety, and privacy features.
 endef
 
 define Package/tor/conffiles
@@ -69,7 +69,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
 fi
 
 if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $name to /etc/passwd"
+        echo "adding user $$name to /etc/passwd"
         echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 endef
@@ -77,16 +77,21 @@ endef
 CONFIGURE_ARGS += \
        --with-libevent-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
-       , \
-       CROSS_COMPILE=yes
 
-define Package/tor/install     
+CONFIGURE_VARS += \
+       CROSS_COMPILE="yes" \
+
+# pass CFLAGS again to override -O2 set by configure
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+
+define Package/tor/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/or/tor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
        $(INSTALL_DIR) $(1)/etc/tor
-       $(INSTALL_DATA) ./files/torrc $(1)/etc/tor/torrc
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
 $(eval $(call BuildPackage,tor))