tweak tor Makefile and remove unneeded intrusive patch
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index a82531952806c7ee9694a44580330beeee8dc342..987bdd43e1ad73e94793b934733c5347fce2021a 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.1.0.17
+PKG_VERSION:=0.1.1.24
 PKG_RELEASE:=1
-PKG_MD5SUM:=83c4afe29fa82473afcb2ec7e17771b9
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://tor.eff.org/dist/ \
        http://ftp.se.linux.org/crypto/tor/ \
        http://tor.meulie.net/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=28dea6a77a43b6e421e1bd7b2cc3d940
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -29,12 +29,13 @@ define Package/tor
   CATEGORY:=Network
   DEPENDS:=+libevent +libopenssl +libpthread +zlib
   TITLE:=An anonymous Internet communication system
-  DESCRIPTION:=Tor is a toolset for a wide range of organizations and people that want\\\
-  to improve their safety and security on the Internet. Using Tor can\\\
-  help you anonymize web browsing and publishing, instant messaging,\\\
-  IRC, SSH, and more. Tor also provides a platform on which software\\\
-  developers can build new applications with built-in anonymity, safety,\\\
-  and privacy features.\\\
+  DESCRIPTION:=\
+       Tor is a toolset for a wide range of organizations and people that want \\\
+       to improve their safety and security on the Internet. Using Tor can \\\
+       help you anonymize web browsing and publishing, instant messaging, \\\
+       IRC, SSH, and more. Tor also provides a platform on which software \\\
+       developers can build new applications with built-in anonymity, safety, \\\
+       and privacy features.
   URL:=http://tor.eff.org/
 endef
 
@@ -50,10 +51,10 @@ id=52
 
 # do not change below
 # # check if we are on real system
-# if [ -z "${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $5 }'`
-        if [ "$rootfs" = "squashfs" ]; then
+if [ -z "$${IPKG_INSTROOT}" ]; then
+        # create copies of passwd and group, if we use squashfs
+        rootfs=`mount |awk '/root/ { print $$5 }'`
+        if [ "$$rootfs" = "squashfs" ]; then
                 if [ -h /etc/group ]; then
                         rm /etc/group
                         cp /rom/etc/group /etc/group
@@ -66,38 +67,43 @@ id=52
 fi
 
 echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $name to /etc/group"
-        echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+        echo "adding group $$name to /etc/group"
+        echo "$${name}:x:$${id}:" >> ${IPKG_INSTROOT}/etc/group
 fi
 
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
         echo "adding user $name to /etc/passwd"
-        echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
+        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                  --disable-static,ac_cv_libevent_normal=yes \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
+       $(call Build/Configure/Default,\
+               --with-libevent-dir="$(STAGING_DIR)/usr" \
+               --with-ssl-dir="$(STAGING_DIR)/usr" \
+               , \
+               ac_cv_libevent_linker_option='(none)' \
+               ac_cv_openssl_linker_option='(none)' \
                tor_cv_null_is_zero=yes \
-               tor_cv_unaligned_ok=yes)
+               tor_cv_unaligned_ok=yes \
+               tor_cv_time_t_signed=yes \
+       )
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Package/tor/install     
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/tor.init $(1)/etc/init.d/tor
-       install -d -m0755 $(1)/etc/tor
-       install -m0644 ./files/torrc $(1)/etc/tor/torrc
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
+       $(INSTALL_DIR) $(1)/etc/tor
+       $(INSTALL_DATA) ./files/torrc $(1)/etc/tor/torrc
 endef
 
 $(eval $(call BuildPackage,tor))
-