START/STOP values must be specified in the init script
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index d853b95c549f8b89aa9d1aa461e80c8f8a8e062b..987bdd43e1ad73e94793b934733c5347fce2021a 100644 (file)
@@ -79,22 +79,15 @@ fi
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.in \
-               aclocal.m4 \
-               Makefile.in \
-               configure \
-       );
        $(call Build/Configure/Default,\
-               --with-libevent-dir="$(STAGING_DIR)/usr/" \
-               --with-gnu-ld \
+               --with-libevent-dir="$(STAGING_DIR)/usr" \
+               --with-ssl-dir="$(STAGING_DIR)/usr" \
                , \
-               ac_cv_libevent_normal=yes \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
+               ac_cv_libevent_linker_option='(none)' \
+               ac_cv_openssl_linker_option='(none)' \
                tor_cv_null_is_zero=yes \
                tor_cv_unaligned_ok=yes \
                tor_cv_time_t_signed=yes \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -levent" \
        )
 endef
 
@@ -105,12 +98,12 @@ define Build/Compile
 endef
 
 define Package/tor/install     
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/tor.init $(1)/etc/init.d/tor
-       install -d -m0755 $(1)/etc/tor
-       install -m0644 ./files/torrc $(1)/etc/tor/torrc
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
+       $(INSTALL_DIR) $(1)/etc/tor
+       $(INSTALL_DATA) ./files/torrc $(1)/etc/tor/torrc
 endef
 
 $(eval $(call BuildPackage,tor))