[packages] tor: update to 0.2.1.23
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index 16b6f23cc3e94bab988e1cdfc1038c34c362ee92..d987f6cade2576199bca4949869ee96bf65b4fce 100644 (file)
@@ -1,42 +1,38 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.1.1.24
+PKG_VERSION:=0.2.1.23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://tor.eff.org/dist/ \
-       http://ftp.se.linux.org/crypto/tor/ \
-       http://tor.meulie.net/
-PKG_MD5SUM:=28dea6a77a43b6e421e1bd7b2cc3d940
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.torproject.org/dist
+PKG_MD5SUM:=2e0bf3dbb83bbaadaa99d1dfe59c75f7
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tor
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread +zlib
+  DEPENDS:=+libevent +libopenssl +libpthread
   TITLE:=An anonymous Internet communication system
-  DESCRIPTION:=\
-       Tor is a toolset for a wide range of organizations and people that want \\\
-       to improve their safety and security on the Internet. Using Tor can \\\
-       help you anonymize web browsing and publishing, instant messaging, \\\
-       IRC, SSH, and more. Tor also provides a platform on which software \\\
-       developers can build new applications with built-in anonymity, safety, \\\
-       and privacy features.
-  URL:=http://tor.eff.org/
+  URL:=http://www.torproject.org/
+endef
+
+define Package/tor/description
+ Tor is a toolset for a wide range of organizations and people that want to
+ improve their safety and security on the Internet. Using Tor can help you
+ anonymize web browsing and publishing, instant messaging, IRC, SSH, and
+ more. Tor also provides a platform on which software developers can build
+ new applications with built-in anonymity, safety, and privacy features.
 endef
 
 define Package/tor/conffiles
@@ -69,42 +65,33 @@ fi
 echo ""
 if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
         echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> ${IPKG_INSTROOT}/etc/group
+        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
 fi
 
 if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $name to /etc/passwd"
+        echo "adding user $$name to /etc/passwd"
         echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --with-libevent-dir="$(STAGING_DIR)/usr/" \
-               --with-gnu-ld \
-               , \
-               ac_cv_libevent_normal=yes \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
-               tor_cv_null_is_zero=yes \
-               tor_cv_unaligned_ok=yes \
-               tor_cv_time_t_signed=yes \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -levent" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-libevent-dir="$(STAGING_DIR)/usr" \
+       --with-ssl-dir="$(STAGING_DIR)/usr" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       CROSS_COMPILE="yes" \
+
+# pass CFLAGS again to override -O2 set by configure
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
 
-define Package/tor/install     
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/tor.init $(1)/etc/init.d/tor
-       install -d -m0755 $(1)/etc/tor
-       install -m0644 ./files/torrc $(1)/etc/tor/torrc
+define Package/tor/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
+       $(INSTALL_DIR) $(1)/etc/tor
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
 $(eval $(call BuildPackage,tor))