packages/znc: remove redundant configure args
[openwrt/svn-archive/archive.git] / net / ucarp / Makefile
index 77d63f4a422e7077ffc346e4f555828406d9e487..67afdfc3032ffafdd6ae758ae64023695c0403a3 100644 (file)
@@ -1,16 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucarp
-PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=1.5.2
+PKG_RELEASE:=3
 
-PKG_MD5SUM:=9219ea8214198e8af751353a132087bb
-PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
+PKG_MD5SUM:=723636dbf79fc6abd329a71ec4ddf79d
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,7 +23,8 @@ define Package/ucarp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Lets several hosts share one IP
-  URL:=http://carp.org
+  DEPENDS:=+ip +libpcap
+  URL:=http://www.ucarp.org/project/ucarp
 endef
 
 define Package/ucarp/description
@@ -27,9 +33,17 @@ define Package/ucarp/description
  secure and patent-free Common Address Redundancy Protocol
 endef
 
+define Package/ucarp/conffiles
+/etc/ucarp.conf
+endef
+
 define Package/ucarp/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ucarp $(1)/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/ucarp.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ucarp.init $(1)/etc/init.d/ucarp
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ucarp $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ucarp))