updatedd:
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index 100d6da53ac29c674ac2587cbd391176b204726d..28bda335c007f14d2625e7976d1e9aeac30c1423 100644 (file)
@@ -10,12 +10,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=updatedd
 PKG_VERSION:=2.5
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 PKG_MD5SUM:=2957496de0c8e08e9c6492fabf1a88be
 
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/updatedd/
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -29,7 +28,7 @@ define Package/updatedd
   TITLE:=A tool to update dynamic dns services
   DESCRIPTION:=Updatedd is a small tool that will update one of many dynamic\\\
   dns services on boot.\\\
-  Please look at the /etc/init.d/S55ddns script for more info.\\\
+  Please look at the /etc/init.d/ddns script for more info.\\\
   URL:=http://www.philipp-benner.de/updatedd/
 endef
 
@@ -96,26 +95,36 @@ define Package/updatedd-mod-tzo
   TITLE:=tzo.com
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
+define Package/updatedd-mod-zoneedit
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=updatedd
+  TITLE:=zoneedit.com
 endef
 
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
+
 define BuildPlugin
   define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/updatedd
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
+       $(INSTALL_DIR) $$(1)/usr/lib/updatedd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
 define Package/updatedd/install
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/S55ddns $(1)/etc/init.d/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/updatedd.init $(1)/etc/init.d/updatedd
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/updatedd.config $(1)/etc/config/updatedd
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_BIN) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))
@@ -128,3 +137,4 @@ $(eval $(call BuildPlugin,updatedd-mod-ods,ods))
 $(eval $(call BuildPlugin,updatedd-mod-ovh,ovh))
 $(eval $(call BuildPlugin,updatedd-mod-regfish,regfish))
 $(eval $(call BuildPlugin,updatedd-mod-tzo,tzo))
+$(eval $(call BuildPlugin,updatedd-mod-zoneedit,zoneedit))