replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index 79f220e1f5cabf66bd672bed8552a5f46a391e55..7c8f9ed1dbbd989bfba99bea0d6c769973156f9e 100644 (file)
@@ -103,19 +103,19 @@ endef
 
 define BuildPlugin
   define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/updatedd
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
+       $(INSTALL_DIR) $$(1)/usr/lib/updatedd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
 define Package/updatedd/install
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/ddns.init $(1)/etc/init.d/ddns
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ddns.init $(1)/etc/init.d/ddns
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/usr/lib/updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))