[packages] updatedd: mark uci as config file (#6766)
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index d6952f43b390eebeed02f2217243dd6695aad55f..d106c8b272492e682dbe2957e5e280da40f951e1 100644 (file)
@@ -1,24 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=updatedd
-PKG_VERSION:=2.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=2957496de0c8e08e9c6492fabf1a88be
+PKG_VERSION:=2.6
+PKG_RELEASE:=7
 
-PKG_SOURCE_URL:=http://savannah.nongnu.org/download/updatedd/
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=f03446105ed043cd5dbd1ab95484d27f
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,10 +25,18 @@ define Package/updatedd
   CATEGORY:=Network
   MENU:=1
   TITLE:=A tool to update dynamic dns services
-  DESCRIPTION:=Updatedd is a small tool that will update one of many dynamic\\\
-  dns services on boot.\\\
-  Please look at the /etc/init.d/ddns script for more info.\\\
-  URL:=http://www.philipp-benner.de/updatedd/
+  URL:=http://savannah.nongnu.org/projects/updatedd/
+endef
+
+define Package/updatedd/description
+Updatedd is a small tool that will update one of many dynamic 
+       dns services on boot. 
+       Please look at the /etc/init.d/ddns script for more info. 
+
+endef
+
+define Package/updatedd/conffiles
+/etc/config/updatedd
 endef
 
 define Package/updatedd-mod-changeip
@@ -96,15 +102,22 @@ define Package/updatedd-mod-tzo
   TITLE:=tzo.com
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
+define Package/updatedd-mod-zoneedit
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=updatedd
+  TITLE:=zoneedit.com
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake )
+       $(call Build/Configure/Default)
 endef
 
 define BuildPlugin
   define Package/$(1)/install
        $(INSTALL_DIR) $$(1)/usr/lib/updatedd
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so* $$(1)/usr/lib/updatedd/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
@@ -112,23 +125,24 @@ endef
 
 define Package/updatedd/install
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/ddns.init $(1)/etc/init.d/ddns
+       $(INSTALL_BIN) ./files/updatedd.init $(1)/etc/init.d/updatedd
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/ddns.config $(1)/etc/config/updatedd
+       $(INSTALL_DATA) ./files/updatedd.config $(1)/etc/config/updatedd
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/updatedd
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-        $(INSTALL_BIN) ./files/ddns.hotplug $(1)/etc/hotplug.d/iface/10-ddns
+       $(INSTALL_DATA) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))
-$(eval $(call BuildPlugin,updatedd-mod-changeip,changeip))
-$(eval $(call BuildPlugin,updatedd-mod-dyndns,dyndns))
-$(eval $(call BuildPlugin,updatedd-mod-eurodyndns,eurodyndns))
-$(eval $(call BuildPlugin,updatedd-mod-hn,hn))
-$(eval $(call BuildPlugin,updatedd-mod-noip,noip))
-$(eval $(call BuildPlugin,updatedd-mod-ods,ods))
-$(eval $(call BuildPlugin,updatedd-mod-ovh,ovh))
-$(eval $(call BuildPlugin,updatedd-mod-regfish,regfish))
-$(eval $(call BuildPlugin,updatedd-mod-tzo,tzo))
+$(eval $(call BuildPlugin,updatedd-mod-changeip,libchangeip))
+$(eval $(call BuildPlugin,updatedd-mod-dyndns,libdyndns))
+$(eval $(call BuildPlugin,updatedd-mod-eurodyndns,libeurodyndns))
+$(eval $(call BuildPlugin,updatedd-mod-hn,libhn))
+$(eval $(call BuildPlugin,updatedd-mod-noip,libnoip))
+$(eval $(call BuildPlugin,updatedd-mod-ods,libods))
+$(eval $(call BuildPlugin,updatedd-mod-ovh,libovh))
+$(eval $(call BuildPlugin,updatedd-mod-regfish,libregfish))
+$(eval $(call BuildPlugin,updatedd-mod-tzo,libtzo))
+$(eval $(call BuildPlugin,updatedd-mod-zoneedit,libzoneedit))