Convert updatedd to the uci config format, add a hotplug script as well (#1213)
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index 100d6da53ac29c674ac2587cbd391176b204726d..d5b5d79e1971683ac6bd326b6c0b1f10af7055fa 100644 (file)
@@ -29,7 +29,7 @@ define Package/updatedd
   TITLE:=A tool to update dynamic dns services
   DESCRIPTION:=Updatedd is a small tool that will update one of many dynamic\\\
   dns services on boot.\\\
-  Please look at the /etc/init.d/S55ddns script for more info.\\\
+  Please look at the /etc/init.d/ddns script for more info.\\\
   URL:=http://www.philipp-benner.de/updatedd/
 endef
 
@@ -103,19 +103,21 @@ endef
 
 define BuildPlugin
   define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/updatedd
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
+       $(INSTALL_DIR) $$(1)/usr/lib/updatedd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
 define Package/updatedd/install
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/S55ddns $(1)/etc/init.d/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ddns.init $(1)/etc/init.d/ddns
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/ddns.config $(1)/etc/config/updatedd
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/usr/lib/updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))