Install hosplug script as well
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index 79f220e1f5cabf66bd672bed8552a5f46a391e55..d6952f43b390eebeed02f2217243dd6695aad55f 100644 (file)
@@ -103,19 +103,23 @@ endef
 
 define BuildPlugin
   define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/updatedd
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
+       $(INSTALL_DIR) $$(1)/usr/lib/updatedd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(1)/usr/lib/updatedd/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
 define Package/updatedd/install
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/ddns.init $(1)/etc/init.d/ddns
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ddns.init $(1)/etc/init.d/ddns
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/ddns.config $(1)/etc/config/updatedd
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/usr/lib/updatedd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+        $(INSTALL_BIN) ./files/ddns.hotplug $(1)/etc/hotplug.d/iface/10-ddns
 endef
 
 $(eval $(call BuildPackage,updatedd))