[net] File Transfer: Moved old FTP category and combined with other file transfer...
[openwrt/svn-archive/archive.git] / net / uucp / Makefile
index 9a9b3e0b6c3f92f01e281b721023ad9a90206fd6..73a6cd74327be46957a99e4c0bdbda8bb3dbe5c7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,20 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uucp
 PKG_VERSION:=1.07
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/u/uucp/
-PKG_MD5SUM:=
+PKG_MD5SUM:=64c54d43787339a7cced48390eb3e1d0
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/uucp
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=File Transfer
   TITLE:=copy files to or from another (usually *nix) system
   URL:=http://packages.debian.org/etch/uucp
 endef
@@ -33,14 +37,6 @@ CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-
 define Package/uucp/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(CP) $(PKG_BUILD_DIR)/{cu,tstuu,uu{chk,cico,conv,cp,log,name,pick,sched,stat,to,x,xqt}} $(1)/usr/bin/