update php-apc to 3.0.16, disable pthread mutex's as they are on by default now.
[openwrt/svn-archive/archive.git] / net / vgp / Makefile
index e75a169d85424d3be62c560e6db8c416ba07a6d3..5e4c94daf48db4ad9700ac4075c4efe0f9fafcf7 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://vgpd.freaknet.org/files/
 PKG_MD5SUM:=b8c25b5dfcb944f78bbc584be9c230c7
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,15 +25,17 @@ define Package/vgp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A daemon working like Cisco(c) HSRP
-  DESCRIPTION:=\
-       VGP (Virtual Gateway Protocol)is a very simple protocol able to \\\
-       work in a way similar to Cisco(c) HSRP. It implements the idea \\\
-       of Virtual Gateway to provide fault tollerance (and load \\\
-       balancing) on your net. Each client on your net has as its \\\
-       default gateway set to the virtual gateway and not the real router.
   URL:=http://vgpd.freaknet.org/
 endef
 
+define Package/vgp/description
+       VGP (Virtual Gateway Protocol)is a very simple protocol able to 
+       work in a way similar to Cisco(c) HSRP. It implements the idea 
+       of Virtual Gateway to provide fault tollerance (and load 
+       balancing) on your net. Each client on your net has as its 
+       default gateway set to the virtual gateway and not the real router.
+endef
+
 # uses GNU configure
 
 define Build/Compile
@@ -44,8 +45,8 @@ define Build/Compile
 endef
 
 define Package/vgp/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/vgpd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vgpd $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,vgp))