[package] update usb-modeswitch to 1.0.4 (#5759)
[openwrt/svn-archive/archive.git] / net / vgp / Makefile
index 43cdfa70dcc8f6591df9643bd4f9676be1ddbba6..86e42ccc9700df0f68ff289a797ec44eb4471403 100644 (file)
@@ -4,42 +4,45 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vgp
 PKG_VERSION:=0.2.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=b8c25b5dfcb944f78bbc584be9c230c7
-PKG_SOURCE_URL:=http://vgpd.freaknet.org/files/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://vgpd.freaknet.org/files/
+PKG_MD5SUM:=b8c25b5dfcb944f78bbc584be9c230c7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vgp
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=a daemon working like Cisco(c) HSRP
-  DESCRIPTION:=VGP (Virtual Gateway Protocol)is a very simple protocol able to\\\
-  work in a way similar to Cisco(c) HSRP. It implements the idea\\\
-  of Virtual Gateway to provide fault tollerance (and load\\\
-  balancing) on your net. Each client on your net has as its\\\
-  default gateway the virtual gateway and not the real router.\\\
+  TITLE:=A daemon working like Cisco(c) HSRP
   URL:=http://vgpd.freaknet.org/
 endef
 
+define Package/vgp/description
+       VGP (Virtual Gateway Protocol)is a very simple protocol able to 
+       work in a way similar to Cisco(c) HSRP. It implements the idea 
+       of Virtual Gateway to provide fault tollerance (and load 
+       balancing) on your net. Each client on your net has as its 
+       default gateway set to the virtual gateway and not the real router.
+endef
+
+# uses GNU configure
+
 define Build/Compile
-$(call Build/Compile/Default,DESTDIR=$(PKG_INSTALL_DIR) install)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Package/vgp/install
-       mkdir -p $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vgpd $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,vgp))