[packages] add HAProxy, a high performance HTTP/TCP reverse proxy and load balancer...
[openwrt/svn-archive/archive.git] / net / vnc-reflector / Makefile
index 296e9b87d3092421f5e0b04b1ced15581bc3c764..f6538c88141471b5f92d52f5cca3bc2960334bcb 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/vnc-reflector
 PKG_MD5SUM:=c3f88bc62f228b335c25c07f9744ab0c
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
 
@@ -26,14 +24,16 @@ define Package/vnc-reflector
   CATEGORY:=Network
   DEPENDS:=+libjpeg +zlib
   TITLE:=VNC proxy for multiple clients
-  DESCRIPTION:=\
-       VNC Reflector is a specialized VNC server which acts as \\\
-       a proxy sitting between real VNC server (a host) and a \\\
-       number of VNC clients. It was designed to work efficiently \\\
-       with large number of clients.
   URL:=http://sourceforge.net/projects/vnc-reflector
 endef
 
+define Package/vnc-reflector/description
+       VNC Reflector is a specialized VNC server which acts as 
+       a proxy sitting between real VNC server (a host) and a 
+       number of VNC clients. It was designed to work efficiently 
+       with large number of clients.
+endef
+
 define Build/Compile
        $(call Build/Compile/Default, \
                CC="$(TARGET_CC)" \
@@ -44,8 +44,8 @@ define Build/Compile
 endef
 
 define Package/vnc-reflector/install   
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/vncreflector $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vncreflector $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,vnc-reflector))