remove PKG_CAT from packages
[openwrt/svn-archive/archive.git] / net / vncrepeater / Makefile
index b47a265799a521ee3e3deb33586483bd5cc1c098..9f5330a2a65b7569b8bd3f4d8c7704dfa797a7f2 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
 PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -26,24 +25,26 @@ define Package/vncrepeater
   CATEGORY:=Network
   DEPENDS:=+uclibcxx
   TITLE:=UltraVNC repeater for Linux
-  DESCRIPTION:=\
-       Viewer can be behind Nat router or directly connected to the internet \\\
-       Instead of forwarding serveral ports, you only need to forward 1 port \\\
-       If the PC that runs the Repeater has access to the local DNS server, \\\
-       you can use your local DNS names instead of 10.10.10.12.\\\
-       This could be handy when you have a dynamic DHCP server allocating \\\
-       ip adresses for your PC.
   URL:=http://ultravnc.sourceforge.net/addons/repeater.html
 endef
 
-define Package/vncrepeater/
+define Package/vncrepeater/conffiles
 /etc/vncrepeater.conf
 endef
 
+define Package/vncrepeater/description
+ Viewer can be behind Nat router or directly connected to the internet 
+ instead of forwarding serveral ports, you only need to forward 1 port. 
+ If the PC that runs the Repeater has access to the local DNS server, 
+ you can use your local DNS names instead of 10.10.10.12.
+ This could be handy when you have a dynamic DHCP server allocating 
+ ip adresses for your PC.
+endef
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
-               STAGING_DIR="$(STAGING_DIR)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++" \
                repeater \
        )
 endef