remove PKG_CAT from packages
[openwrt/svn-archive/archive.git] / net / vncrepeater / Makefile
index e2601de6e326bb35cae0c7f331c5f491cc8c06cf..9f5330a2a65b7569b8bd3f4d8c7704dfa797a7f2 100644 (file)
@@ -4,21 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vncrepeater
 PKG_VERSION:=0.12
 PKG_RELEASE:=1
-PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 
-PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
+PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,33 +25,35 @@ define Package/vncrepeater
   CATEGORY:=Network
   DEPENDS:=+uclibcxx
   TITLE:=UltraVNC repeater for Linux
-  DESCRIPTION:=Viewer can be behind Nat router or directly connected to the internet\\\
-  Instead of forwarding serveral ports, you only need to forward 1 port\\\
-  If the PC that runs the Repeater has access to the local DNS server,\\\
-  you can use your local DNS names instead of 10.10.10.12.\\\
-  This could be handy when you have a dynamic DHCP server allocating\\\
-  ip adresses for your PC.\\\
   URL:=http://ultravnc.sourceforge.net/addons/repeater.html
 endef
 
-define Package/vncrepeater/
+define Package/vncrepeater/conffiles
 /etc/vncrepeater.conf
 endef
 
+define Package/vncrepeater/description
+ Viewer can be behind Nat router or directly connected to the internet 
+ instead of forwarding serveral ports, you only need to forward 1 port. 
+ If the PC that runs the Repeater has access to the local DNS server, 
+ you can use your local DNS names instead of 10.10.10.12.
+ This could be handy when you have a dynamic DHCP server allocating 
+ ip adresses for your PC.
+endef
+
 define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               repeater)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++" \
+               repeater \
+       )
 endef
 
 define Package/vncrepeater/install     
-       install -d -m0755 $(1)/usr/sbin $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/repeater $(1)/usr/sbin/$(PKG_NAME)
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/uvncrepeater.ini $(1)/etc/vncrepeater.conf
-       install -d -m0755 $(1)/etc/init.d
-       $(CP) $(PKG_BUILD_DIR)/S60vncrepeater $(1)/etc/init.d/
 endef
 
 $(eval $(call BuildPackage,vncrepeater))