[packages] coova-chilli: update to v1.2.0 (#6501)
[openwrt/svn-archive/archive.git] / net / vpnc / Makefile
index 2fac7e71f85563d67f881d99859fab9ffbb3a158..0b9d07e7aa7a85d73acb3efed2a4880a37c4f9ae 100644 (file)
@@ -4,34 +4,38 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
-PKG_VERSION:=0.3.3
+PKG_VERSION:=0.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vpnc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun
-  TITLE:=VPN client for Cisco 3000
+  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +ip
+  TITLE:=VPN client for Cisco EasyVPN
   URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+  SUBMENU:=VPN
+endef
+
+define Package/vpnc/description
+       A VPN client compatible with Cisco's EasyVPN equipment.
+
+       Supports IPSec (ESP) with Mode Configuration and Xauth.  Supports only
+       shared-secret IPSec authentication with Xauth, AES (256, 192, 128),
+       3DES, 1DES, MD5, SHA1, DH1/2/5 and IP tunneling.
 endef
 
 define Package/vpnc/conffiles
-/etc/vpnc/vpnc.conf
+/etc/vpnc/default.conf
 /etc/vpnc/vpnc-script
 endef
 
@@ -52,7 +56,7 @@ define Package/vpnc/install
                $(PKG_INSTALL_DIR)/usr/sbin/vpnc-disconnect \
                $(1)/usr/sbin/
        install -d -m0700 $(1)/etc/vpnc
-       install -m0600 $(PKG_INSTALL_DIR)/etc/vpnc/vpnc.conf $(1)/etc/vpnc/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vpnc/default.conf $(1)/etc/vpnc/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/vpnc/vpnc-script $(1)/etc/vpnc/
 endef