[patchteam] - fix building of baresip/restund - Signed-off-by: Alfred E. Heggestad...
[openwrt/svn-archive/archive.git] / net / vpnc / Makefile
index 6940c20e9280880615b8655611169bab82037bfb..0b9d07e7aa7a85d73acb3efed2a4880a37c4f9ae 100644 (file)
@@ -4,21 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
-PKG_VERSION:=0.4.0
+PKG_VERSION:=0.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-PKG_MD5SUM:=604807e7dd90fce00a4e2344ee29c76d
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,9 +21,17 @@ define Package/vpnc
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +ip
-  TITLE:=VPN client for Cisco 3000
+  TITLE:=VPN client for Cisco EasyVPN
   URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-  SUBMENU:=vpn
+  SUBMENU:=VPN
+endef
+
+define Package/vpnc/description
+       A VPN client compatible with Cisco's EasyVPN equipment.
+
+       Supports IPSec (ESP) with Mode Configuration and Xauth.  Supports only
+       shared-secret IPSec authentication with Xauth, AES (256, 192, 128),
+       3DES, 1DES, MD5, SHA1, DH1/2/5 and IP tunneling.
 endef
 
 define Package/vpnc/conffiles