fix build under WhiteRussian SDK (closes: #1044)
[openwrt/svn-archive/archive.git] / net / vrrpd / Makefile
index 17344c026dd624630fd5f53d8a4d760c47f55c60..e583b0b671c6bfd9989e2df4e82d50043488c76a 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=vrrpd
 PKG_VERSION:=1.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
 
-PKG_SOURCE_URL:=@SF/vrrpd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/vrrpd
+PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,11 +25,12 @@ define Package/vrrpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Virtual Router Redundancy Protocol daemon
-  DESCRIPTION:=VRRPd is an implementation of Virtual Router Redundancy\\\
-  Protocol as specified in rfc2338.  VRRPd is interoperable with\\\
-  other RFC-based VRRP implementations, including Cisco and\\\
-  Juniper, and is included as a standard feature on ImageStream\\\
-  routers.\\\
+  DESCRIPTION:=\
+       VRRPd is an implementation of Virtual Router Redundancy \\\
+       Protocol as specified in rfc2338.  VRRPd is interoperable with \\\
+       other RFC-based VRRP implementations, including Cisco and \\\
+       Juniper, and is included as a standard feature on ImageStream \\\
+       routers.
   URL:=http://www.sourceforge.net/projects/vrrpd
 endef
 
@@ -38,19 +39,20 @@ define Package/vrrpd/conffiles
 endef
 
 define Build/Compile   
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
+       $(call Build/Compile/Default, \
                DBG_OPT="" \
                MAIN_OPT="$(TARGET_CFLAGS)" \
-               vrrpd)
+               vrrpd \
+       )
 endef
 
 define Package/vrrpd/install   
-       install -d -m0755 $(1)/etc/default
-       install -m0644 ./files/vrrpd.default $(1)/etc/default/vrrpd
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/vrrpd.init $(1)/etc/init.d/vrrpd
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/vrrpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vrrpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_DATA) ./files/vrrpd.default $(1)/etc/default/vrrpd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/vrrpd.init $(1)/etc/init.d/vrrpd
 endef
 
 $(eval $(call BuildPackage,vrrpd))