vsftpd: Cleanup Makefile
[openwrt/svn-archive/archive.git] / net / vsftpd / Makefile
index 90a2b429bd1309fa9cfb00864b571b1b1ac1adf6..051281bc597af5a879b4bfe69dfdf5a6c139b1fe 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.4
-PKG_RELEASE:=1
+PKG_VERSION:=2.0.5
+PKG_RELEASE:=2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=146062e8b2f93af43ff6c2c770feea94
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,24 +29,11 @@ define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               vsftpd install
-endef
-
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/vsftpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vsftpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+       $(INSTALL_CONF) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
 endef