Remove obsolete luaposix package
[openwrt/svn-archive/archive.git] / net / vsftpd / Makefile
index 90a2b429bd1309fa9cfb00864b571b1b1ac1adf6..5d54812d121ebf3bca80dd71fb482e9cdb457201 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.4
-PKG_RELEASE:=1
+PKG_VERSION:=2.0.6
+PKG_RELEASE:=2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=f7a742690d7f86e356fb66d3840079c7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vsftpd
+  SUBMENU:=FTP
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A fast and secure FTP server
@@ -33,26 +30,13 @@ define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               vsftpd install
-endef
-
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/vsftpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+       $(INSTALL_CONF) ./files/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME).conf
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,vsftpd))