[packages] vsftpd: update to 2.3.2
[openwrt/svn-archive/archive.git] / net / vsftpd / Makefile
index 90a2b429bd1309fa9cfb00864b571b1b1ac1adf6..c249c2f9daf4ca55f3e290cfd055997679749061 100644 (file)
@@ -1,58 +1,49 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.4
+PKG_VERSION:=2.3.2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=bad7b117d737a738738836041edc00db
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vsftpd
+  SUBMENU:=FTP
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A fast and secure FTP server
   URL:=http://vsftpd.beasts.org/
+  MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
 endef
 
 define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
-define Build/Configure
-endef
-
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               vsftpd install
+               vsftpd
 endef
 
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/vsftpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+       $(INSTALL_CONF) ./files/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME).conf
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,vsftpd))