[package] updat vsftpd to 2.2.2 (#6191)
[openwrt/svn-archive/archive.git] / net / vsftpd / Makefile
index 051281bc597af5a879b4bfe69dfdf5a6c139b1fe..e829ae1ff18fe669c754b2f30870b25784fa5e78 100644 (file)
@@ -1,24 +1,24 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.5
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=146062e8b2f93af43ff6c2c770feea94
+PKG_MD5SUM:=6d6bc136af14c23f8fef6f1a51f55418
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vsftpd
+  SUBMENU:=FTP
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A fast and secure FTP server
@@ -29,13 +29,20 @@ define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               vsftpd
+endef
+
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vsftpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+       $(INSTALL_CONF) ./files/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME).conf
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,vsftpd))