DESCRIPTION:= is obselete
[openwrt/svn-archive/archive.git] / net / wccpd / Makefile
index c1c8f45448118d012f4f3289ffdeeba096992775..5d88da8937940688f769a46e5a3e3fddc8aa7b3c 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=wccpd
 PKG_VERSION:=0.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
 
-PKG_SOURCE_URL:=@SF/wccpd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/wccpd
+PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,28 +26,28 @@ define Package/wccpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=a Web Cache Coordination daemon
-  DESCRIPTION:=wccpd is a WCCP (Web Cache Coordination Protocol) server daemon\\\
-  It allows a router (running Linux) to redirect web traffic to a\\\
-  group of Squid servers using WCCP as the monitoring/controling\\\
-  protocol.\\\
   URL:=http://wccpd.sourceforge.net/
 endef
 
+define Package/wccpd/description
+       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon 
+       It allows a router (running Linux) to redirect web traffic to a 
+       group of Squid servers using WCCP as the monitoring/controling 
+       protocol.
+endef
+
 define Build/Configure
-       $(call Build/Configure/Default,
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --with-gnu-ld \
-       )
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install 
 endef
 
 define Package/wccpd/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
 endef