Makefile cleanups, round 6 and last
[openwrt/svn-archive/archive.git] / net / wccpd / Makefile
index 0dd8e0e49d838c17db1e59028662e025d46b1512..cfb241a08878cdaccc6a278d838ea0c7f7afbe00 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/wccpd
 PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +22,16 @@ define Package/wccpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=a Web Cache Coordination daemon
-  DESCRIPTION:=\
-       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon \\\
-       It allows a router (running Linux) to redirect web traffic to a \\\
-       group of Squid servers using WCCP as the monitoring/controling \\\
-       protocol.
   URL:=http://wccpd.sourceforge.net/
 endef
 
+define Package/wccpd/description
+       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon 
+       It allows a router (running Linux) to redirect web traffic to a 
+       group of Squid servers using WCCP as the monitoring/controling 
+       protocol.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default)
 endef
@@ -46,7 +44,7 @@ endef
 
 define Package/wccpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wccpd))