Upgrade wdiag to 0.9 (#3664)
[openwrt/svn-archive/archive.git] / net / wdiag / Makefile
index 3c8c984af8ac61b2b72e13e976faba83757bfce2..716843d1f88e9ad0c4f1561293d46355ce5934e0 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wdiag
-PKG_VERSION:=0.8
+PKG_VERSION:=0.9
 PKG_RELEASE:=1
 
-PKG_MD5SUM:=248bc2ca318f697e9edce1af945c57bd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/wdiag
-PKG_CAT:=zcat
+PKG_MD5SUM:=26ee93f3e2353ebb5d1df5f3e50eb4fd
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -25,10 +24,13 @@ define Package/wdiag
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Westell DSL Modem Diagnostics for Linux
-  DESCRIPTION:=A collection of utilities to get DSL stats from Westell DSL modems.
   URL:=http://sourceforge.net/projects/wdiag/
 endef
 
+define Package/wdiag/description
+A collection of utilities to get DSL stats from Westell DSL modems.
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
@@ -36,7 +38,7 @@ define Build/Compile
 endef
 
 define Package/wdiag/install
-       install -m0755 -d $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/src/w{start,stop,estell} $(1)/usr/sbin/
 endef