fix weechat compile with the lua plugin
[openwrt/svn-archive/archive.git] / net / weechat / Makefile
index 77b876da47efd977caff04f4648cade74e4da512..3586224355fade05f11eebc4ee9dc18a539c9383 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=weechat
-PKG_VERSION:=0.2.5
-PKG_RELEASE:=2
+PKG_VERSION:=0.2.6
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
-PKG_MD5SUM:=42f96620c3b2fd3dca9768d9ce16dd06
+PKG_MD5SUM:=ccdecf663b0050a23049acb4b9a76193
 
 PKG_FIXUP = libtool
 
@@ -78,24 +78,32 @@ CONFIGURE_ARGS+= \
        --disable-perl \
        --disable-python \
        --disable-ruby \
+       LUACONFIG="" \
 
 CONFIGURE_VARS+= \
-       LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
+       LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib" \
 
-ifndef ($(SDK)$(CONFIG_PACKAGE_weechat-mod-lua),)
+ifneq ($(CONFIG_PACKAGE_weechat-mod-lua),)
   CONFIGURE_ARGS+= \
        --enable-lua \
+       --enable-plugins \
+       --with-plugins="lua" \
        --with-lua-inc="$(STAGING_DIR)/usr/include" \
        --with-lua-lib="$(STAGING_DIR)/usr/lib"
   CONFIGURE_VARS+= \
        LIBS="-ldl -lm"
+  TARGET_LDFLAGS += -lcrypt
 else
   CONFIGURE_ARGS+= \
        --disable-lua
 endif
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(LUA_FLAGS) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               LUACONFIG="" \
+               all install
 endef
 
 define Package/weechat/install