fix weechat compile with the lua plugin
[openwrt/svn-archive/archive.git] / net / weechat / Makefile
index bbc452a9152ed40a7b13b2d5fb171c1852206d52..3586224355fade05f11eebc4ee9dc18a539c9383 100644 (file)
@@ -83,17 +83,16 @@ CONFIGURE_ARGS+= \
 CONFIGURE_VARS+= \
        LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib" \
 
 CONFIGURE_VARS+= \
        LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib" \
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_weechat-mod-lua),)
+ifneq ($(CONFIG_PACKAGE_weechat-mod-lua),)
   CONFIGURE_ARGS+= \
        --enable-lua \
        --enable-plugins \
        --with-plugins="lua" \
        --with-lua-inc="$(STAGING_DIR)/usr/include" \
   CONFIGURE_ARGS+= \
        --enable-lua \
        --enable-plugins \
        --with-plugins="lua" \
        --with-lua-inc="$(STAGING_DIR)/usr/include" \
-       --with-lua-lib="$(STAGING_DIR)/usr/lib" \
-       LUA_CFLAGS="-I$(STAGING_DIR)/usr/include/"
-       LUA_LFLAGS="-L$(STAGING_DIR)/usr/lib -llualib50 -llua50"
+       --with-lua-lib="$(STAGING_DIR)/usr/lib"
   CONFIGURE_VARS+= \
        LIBS="-ldl -lm"
   CONFIGURE_VARS+= \
        LIBS="-ldl -lm"
+  TARGET_LDFLAGS += -lcrypt
 else
   CONFIGURE_ARGS+= \
        --disable-lua
 else
   CONFIGURE_ARGS+= \
        --disable-lua