Disable the lua plugin for now, until it is fixed
[openwrt/svn-archive/archive.git] / net / weechat / Makefile
index 3dd6d28e8b2e2eb1fe028ee173c11bddee809156..fdcf0b1ecf7559788b8406dd16fdb81779f07b2f 100644 (file)
@@ -37,7 +37,7 @@ define Build/Configure
                --with-debug=0 \
                --with-libgnutls-prefix=$(STAGING_DIR)/usr \
                --without-doc-xsl-prefix \
-               --without-libiconv-prefix \
+               --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
                --without-libintl-prefix \
                --disable-aspell \
                --enable-lua \
@@ -47,7 +47,7 @@ define Build/Configure
                --disable-python \
                --disable-ruby \
                , \
-               LIBS="-llua -ldl -lm" \
+               LIBS="-llua -ldl -lm -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
        )
 endef
 
@@ -61,7 +61,8 @@ define Package/weechat/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/weechat-curses $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/weechat/plugins
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/weechat/plugins/lua.so* $(1)/usr/lib/weechat/plugins/
+       # FIXME : weechat is not configured to compile with lua since 0.2.4
+       #$(CP) $(PKG_INSTALL_DIR)/usr/lib/weechat/plugins/lua.so* $(1)/usr/lib/weechat/plugins/
 endef
+
 $(eval $(call BuildPackage,weechat))