[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / wifidog / Makefile
index 5105b142a0cc903a55c393e4c4c57ba85a9bbf6c..9fdc0feb91cb8bd77604c44595c104faf06387ea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,55 +9,52 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
-PKG_VERSION:=1.1.3_beta2
+PKG_VERSION:=1.1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= @SF/$(PKG_NAME)
-PKG_MD5SUM:=ba1611c7eb959f9c6f93e12b97d70b82
-PKG_CAT:=zcat
+PKG_MD5SUM:=daa4f492dd6acafe0a7127d07633aca5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wifidog
+  SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables-mod-extra
+  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +iptables-mod-nat +libpthread
   TITLE:=A wireless captive portal solution
-  DESCRIPTION:=\
-       The Wifidog project is a complete and embeddable captive \\\
-       portal solution for wireless community groups or individuals \\\
-       who wish to open a free Hotspot while still preventing abuse \\\
-       of their Internet connection.
   URL:=http://www.wifidog.org
 endef
 
+define Package/wifidog/description
+       The Wifidog project is a complete and embeddable captive 
+       portal solution for wireless community groups or individuals 
+       who wish to open a free Hotspot while still preventing abuse 
+       of their Internet connection.
+endef
+
 define Package/wifidog/conffiles
 /etc/wifidog.conf
 endef
 
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
        
 define Package/wifidog/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/scripts/init.d/wifidog $(1)/usr/bin/wifidog-init
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wifidog $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wdctl $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/init.d/wifidog $(1)/usr/bin/wifidog-init
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wifidog $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wdctl $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/wifidog.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/wifidog.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
 endef
 
 $(eval $(call BuildPackage,wifidog))