[packages] baresip: fix compilation
[openwrt/svn-archive/archive.git] / net / wifidog / Makefile
index 8c6f1104e651e605c7c8780ca5ec02f8c4e4d19a..db017191a8cb5367a0024681cf924880083b9628 100644 (file)
@@ -1,24 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
-PKG_VERSION:=1.1.3_rc1
+PKG_VERSION:=20090925
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= @SF/$(PKG_NAME)
-PKG_MD5SUM:=2df210852bace3eb740f9344b843f6c3
-PKG_CAT:=zcat
+PKG_MD5SUM:=e3ecacba67a91b6ea3c1072ba6c5a0b4
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,33 +24,32 @@ define Package/wifidog
   SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +iptables-mod-nat +libgcc +libpthread
+  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +iptables-mod-nat +iptables-mod-nat-extra +libpthread
   TITLE:=A wireless captive portal solution
-  DESCRIPTION:=\
-       The Wifidog project is a complete and embeddable captive \\\
-       portal solution for wireless community groups or individuals \\\
-       who wish to open a free Hotspot while still preventing abuse \\\
-       of their Internet connection.
   URL:=http://www.wifidog.org
 endef
 
+define Package/wifidog/description
+       The Wifidog project is a complete and embeddable captive
+       portal solution for wireless community groups or individuals
+       who wish to open a free Hotspot while still preventing abuse
+       of their Internet connection.
+endef
+
 define Package/wifidog/conffiles
 /etc/wifidog.conf
 endef
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-       
 define Package/wifidog/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/init.d/wifidog $(1)/usr/bin/wifidog-init
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wifidog $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wdctl $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wifidog $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wdctl $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/wifidog.conf $(1)/etc/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog-msg.html $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
 endef