[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / wiviz / Makefile
index ff7cc5f827515a093ff5d913dd460ff7a6bc79b7..d68ef9f6c3e7fd5b460c73f75492f1d49ccc3deb 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -21,7 +20,7 @@ define Package/wiviz
   CATEGORY:=Network
   DEPENDS:=+libpcap
   TITLE:=Wireless Network Visualization
-  URL:=http://students.washington.edu/natetrue/wiviz/
+  URL:=http://devices.natetrue.com/wiviz/
 endef
        
 define Build/Prepare
@@ -29,10 +28,13 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               CCOPTS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-               INCLUDE="" \
+               CCOPTS="$(TARGET_CFLAGS)" \
+               INCLUDE="$(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef